VPN Cisco

Aus wiki@ANOnet
Wechseln zu: Navigation, Suche

Inhaltsverzeichnis

IPSEC-Config

ISAKMP

crypto isakmp policy 1
encryption 3des
hash sha
authentication pre-share
group 2


Key festlegen

Eine Gegenstelle

crypto isakmp key **** address xxx.xxx.xxx.xxx


n Gegenstellen

crypto isakmp key **** address 0.0.0.0 0.0.0.0


Crypto-Accesslisten

Hier wird der zu verschlüsselnde Verkehr definiert

access-list 101 deny udp any any eq isakmp
access-list 101 permit gre host [QuellIP-LAN] host [ZielIP-LAN]
access-list 101 permit ip [Quellnetz] [Zielnetz]


Transformset erstellen

crypto ipsec transform-set [Tunnelname] esp-3des esp-sha-hmac

CryptoMap

Hier werden Crypto-Accesslists und Transformset verknüpft


Eine Gegenstelle

crypto map [MAPname]1 ipsec-isakmp
set peer xxx.xxx.xxx.xxx
set transform-set [Set-Name]
set pfs group2
match address 101

n Gegenstellen

crypto dynamic-map [Mapname-Dynamisch] 1
set transform-set [Set-Name]
set pfs group2
match address 101
exit
crypto map [Mapname] 1 ipsec-isakmp dynamic [Mapname-Dynamisch]

Binden ans Interface

interface [Outside-IF]
crypto map [Mapname]



Clients

ShrewSoft VPN Client

  • Freier Client, zu beziehen unter [1]
  • auch für 64-bit-Systeme sowie für Linux

Konfiguration:

Meine Werkzeuge
Namensräume

Varianten
Aktionen
Navigation
Werkzeuge